Linux & Co
Accueil du siteLinux
Dernière mise à jour :
mercredi 13 décembre 2006
Statistiques éditoriales :
44 Articles
1 Brève
3 Sites Web
81 Auteurs

Statistiques des visites :
4 aujourd'hui
0 hier
13891 depuis le début
   
Linux-restricted
samedi 26 août 2006
par Johann Lahitte

Cette après-midi, petite galére en perspective avec ma Ubuntu. Je tente d’installer le kernel qui va bien sur mon ordi (linux-image 2.6.15-26-686) qui permet donc de gérer mon proc bi-coeur. Un petit reboot plus tard, ... stupeur !!... Plus de carte wifi de détecté ! Alors que tout fonctionnait bien sous l’ancien noyau de base (version 386). Un post sur le forum d’ubuntu-fr, et on me souffle la réponse : Il faut installer le package linux-restricted allant bien avec mon noyau. Mais qu’est ce que c’est que ca Linux-restricted ?

Si on se refére au descriptif de package ubuntu, on obtient ca :

This package provides restricted modules for Linux version 2.6.10 on Pentium Pro/Celeron/Pentium II/Pentium III/Pentium IV with SMP support. Currently the following modules are included :

- madwifi (Atheros)

- fglrx (ATI)

- nvidia

- fcdsl, fcdsl2, fcdslsl, fcdslslusb, fcdslusb, fcdslusba, fcpci, fcpcmcia, fcpcmcia_cs, fcusb, fxusb (AVM ISDN)

- ltmodem (Winmodem)

These modules are "restricted" because they are not available under a completely Free licence.

Il s’agit donc en faite de logiciel qui n’ont pas de licence complétement gratuite. Donc si un jour prochain vous avez des problémes hardware à l’update de votre noyau, pensez Linux-restricted !